LoginRegisterCommercial SupportContact Us


Development & IT > System Requirements

System Requirements

posted on 1:50 PM, May 28, 2012

ExSite runs best on a LAMP server:

  • Webserver that supports CGI (Apache 2 recommended)
  • database (MySQL 5.1 recommended - need not be on same server)
  • Perl 5 (5.10 recommended)

The following Perl modules are used by ExSite, and should either be installed in the system Perl libraries, or in subdirectories of the website's cgi-bin. Most Linux distros will have packages for these; if not, you can find the necessary packages at cpan.org:

  • CGI
  • Carp
  • Devel::Size
  • Digest::MD5
  • MIME::Base64
  • Net::SMTP
  • Image::Info
  • IO::String
  • Spreadsheet::WriteExcel
  • LWP

The convert program (part of the ImageMagick image processing suite) is used for thumbnailing and image scaling operations, if it is available. It is also used as a fallback for Image::Info, if that package is unavailable.

The make program is used for installation; you will need shell access to the server to use this.

updated December 2016
Filed under: IT